Amazon RDS for PostgreSQL コネクターのメッセージおよび制限事項

 

オペレーションについては「Amazon RDS for PostgreSQL」(オペレーショントップページ)を参照してください。

AMAZONRDSPOSTGRESQLカテゴリのメッセージコード一覧

Amazon RDS for PostgreSQL Connectorで発生するエラーに対応するメッセージコードです。

 

AMAZONRDSPOSTGRESQL0000E

定義されていないエラーが発生した場合に出力されるメッセージコードです。

原因

対策

定義されていないエラーが発生しました。

エラーメッセージやエラーが発生した処理のヘルプなどを確認してください。

対応するエラー

  • 特になし

 

AMAZONRDSPOSTGRESQL0001E

データベース処理中のエラーに対応するメッセージコードです。

原因

対策

エラーメッセージにより、原因は異なります。

エラーメッセージを確認し、以下のことを行ってください。

  • 下記の「例外メッセージ」に対象のエラーの原因/対策が記述されていないかを確認してください。

  • 使用しているコネクターの制限事項に対象のエラーの原因/対策が記述されていないかを確認してください。

  • 接続先のデータベースのドキュメントなどに対象のエラーに関する情報がないか確認してください。

対応するエラー

  • java.sql.SQLException

  • org.postgresql.util.PSQLException

 

AMAZONRDSPOSTGRESQLカテゴリの例外メッセージ

バージョンによって表示されるエラーメッセージが異なるため、該当するバージョンのメッセージを確認してください。

バージョン

例外名

原因

対策

共通

InputDataNotFoundException

入力データが指定されていません。

入力データを指定する、またはデータフローを引いてください。

共通

InvalidPropertyConfigurationException

SQL文が未設定です。

SQL文を指定してください。

共通

InvalidPropertyConfigurationException

書き込み対象カラムが選択されていません。

スキーマ定義の書き込み対象が選択されていません。

スキーマ定義の書き込み対象を1つ以上選択してください。

共通

InvalidPropertyConfigurationException

読み取り対象カラムが選択されていません。

スキーマ定義の読み取り対象が選択されていません。

スキーマ定義の読み取り対象を1つ以上選択してください。

共通

InvalidPropertyConfigurationException

テーブル名が未設定です。

テーブル名を指定してください。

共通

java.sql.SQLException

データベースアクセスエラーまたはそのほかのエラーが発生しています。

SQLExceptionのメッセージを確認してください。SQLExceptionのメッセージは各ドライバの仕様に基づいています。SQLExceptionのメッセージにはエラーの原因が出力されている場合があります。

メッセージの詳細については、各データベースベンダーに問い合わせてください。

共通

ResourceNotFoundException

リソース定義が見つかりませんでした。名前:[]

接続先が指定されていません。

接続先を指定してください。

共通

ResourceNotFoundException

リソース定義が見つかりませんでした。名前:[<コネクションリソース名>]

接続先で選択されたリソース定義が見つかりません。

接続先で指定したコネクションリソースを確認してください。

共通

org.postgresql.util.PSQLException

FATAL: database "<データベース名>" does not exist

データベースが存在しません。

コネクションリソースのデータベース名で存在するデータベースを指定してください。

共通

FATAL: password authentication failed for user "<ユーザー名>"

ユーザー名またはパスワードに誤りがあります。

コネクションリソースのユーザー名とパスワードを確認してください。

17

ERROR: syntax error at or near "<テーブル名に含まれる不正な文字列>"

テーブル名が不正です。

テーブル名で指定したテーブル名を確認してください。

16、15、12

ERROR: syntax error at or near "<テーブル名>"

テーブル名が不正です。

テーブル名で指定したテーブル名を確認してください。

共通

ERROR: relation "<テーブル名>" does not exist

テーブルが存在しません。

テーブル名で存在するテーブルを指定してください。

共通

ERROR: permission denied for table <テーブル名>

テーブルの読み取り権限がありません。

テーブル名で指定したテーブルの読み取り権限を確認してください。

共通

接続試行は失敗しました。

データベースに接続できません。

コネクションリソースのホスト名とポート番号を確認してください。

 

AMAZONRDSPOSTGRESQLカテゴリの制限事項

閉じたAmazon RDS for PostgreSQL 17の仕様制限

 

VPCエンドポイント経由でのSSL接続について

以下のコネクションを作成する際に、SSL接続のチェックをオンにして、VPCエンドポイント経由で接続する場合は、接続先のホスト名とRDSの証明書のホスト名が一致しないため、SSL handshakeでエラーが発生します。

  • Amazon RDS for PostgreSQL 17接続

回避策

以下のいずれかを実施してください。

  • PrivateLinkのアウトバウンド設定において、エイリアスに接続先 PostgreSQLのホスト名を設定してください。その後、コネクション設定画面でSSL接続を選択してください。

  • SSL接続を選択し、URLを直接入力するを選択してください。URLで「&sslmode=verify-ca」を追記してください。この場合ホスト名検証は行われなくなります。

    例 :「ssl=true&sslfactory=」を「 ssl=true&sslmode=verify-ca&sslfactory=」に変更

サポートする型

本コネクターでサポートする型は以下のとおりです。

型名

サポート

備考

BIGINT型

○

 

BIGSERIAL型

×

 

BIT[(n)]型

×

 

BIT VARYING[(n)]型

△

 

BOOLEAN型

○

 

BOX型

×

 

BYTEA型

△

 

MONEY型

×

 

CHARACTER[(n)]型

△

 

CHARACTER VARYING[(n)]型

△

 

CIDR型

△

 

CIRCLE型

△

 

DATE型

○

 

DOUBLE PRECISION型

○

 

INET型

△

 

INTEGER型

○

 

INTERVAL[(p)]型

△

 

LINE型

×

 

LSEG型

△

 

MACADDR型

△

 

MACADDR8型

×

 

NUMERIC[(p,s)]型

○

 

PATH型

△

 

POINT型

△

 

POLYGON型

△

 

REAL型

○

 

SMALLINT型

○

 

SERIAL型

×

 

SMALLSERIAL型

×

 

TEXT型

△

 

TIME[(P)]型

×

 

TIME[(P)] WITH TIME ZONE型

×

 

TIMESTAMP[(P)]型

○

 

TIMESTAMP[(P)] WITH TIME ZONE型

○

 

ARRAY型

△

 

UUID型

×

 

ENUM型

×

 

XML型

×

 

JSON型

×

 

JSONB型

×

 

RANGE型

×

 

TSQUERY型

×

 

TSVECTOR型

×

 

PG_LSN型

×

 

PG_SNAPSHOT型

×

 

  • ○:サポートします。

  • △:サポートしますが、制限事項があります。

  • ×:サポートしません。

 

テーブル読み取り処理

仕様制限

  • BYTEA型

    • 半角バックスラッシュ(「\」)と半角アポストロフィ(「'」)はサポートしません。

  • テーブル名が引用符で囲われている場合、テーブル名の大文字小文字を区別します。

  • フェッチサイズのデフォルト値は「500」です。

 

検索系SQL実行処理

仕様制限

  • BYTEA型

    • 半角バックスラッシュ(「\」)と半角アポストロフィ(「'」)はサポートしません。

  • フェッチサイズのデフォルト値は「500」です。

 

テーブル書き込み処理

仕様制限

  • 以下の型はサポートしません。

    • CIDR型

    • CIRCLE型

    • INTERVAL型

    • LSEG型

    • PATH型

    • POINT型

    • POLYGON型

    • BIT VARYING型

    • BIT VARYING(N)型

    • ARRAY型

    • INET型

    • MACADDR型

  • BYTEA型

    • 半角バックスラッシュ(「\」)と半角アポストロフィ(「'」)はサポートしません。

  • テーブル名が引用符で囲われている場合、テーブル名の大文字小文字を区別します。

  • アップデートモードのインサート・アップデートは使用できません。

 

更新系SQL実行処理

仕様制限

  • 以下の型はサポートしません。

    • CIDR型

    • CIRCLE型

    • INTERVAL型

    • LSEG型

    • PATH型

    • POINT型

    • POLYGON型

    • BIT VARYING型

    • BIT VARYING(N)型

    • ARRAY型

    • INET型

    • MACADDR型

  • BYTEA型

    • 半角バックスラッシュ(「\」)と半角アポストロフィ(「'」)はサポートしません。

閉じたAmazon RDS for PostgreSQL 16、15、12の仕様制限

VPCエンドポイント経由でのSSL接続について

以下のコネクションを作成する際に、SSL接続のチェックをオンにして、VPCエンドポイント経由で接続する場合は、接続先のホスト名とRDSの証明書のホスト名が一致しないため、SSL handshakeでエラーが発生します。

  • Amazon RDS for PostgreSQL 16接続

  • Amazon RDS for PostgreSQL 15接続

  • Amazon RDS for PostgreSQL 12接続

回避策

以下のいずれかを実施してください。

  • PrivateLinkのアウトバウンド設定において、エイリアスに接続先 PostgreSQLのホスト名を設定してください。その後、コネクション設定画面でSSL接続を選択してください。

  • SSL接続を選択し、URLを直接入力するを選択してください。URLで「&sslmode=verify-ca」を追記してください。この場合ホスト名検証は行われなくなります。

    例 :「ssl=true&sslfactory=」を「 ssl=true&sslmode=verify-ca&sslfactory=」に変更

 

サポートする型

本コネクターでサポートする型は以下のとおりです。

型名

サポート

備考

BIGINT型

○

 

BIGSERIAL型

×

 

BIT[(n)]型

×

 

BIT VARYING[(n)]型

△

 

BOOLEAN型

○

 

BOX型

×

 

BYTEA型

△

 

MONEY型

×

 

CHARACTER[(n)]型

△

 

CHARACTER VARYING[(n)]型

△

 

CIDR型

△

 

CIRCLE型

△

 

DATE型

○

 

DOUBLE PRECISION型

○

 

INET型

△

 

INTEGER型

○

 

INTERVAL[(p)]型

△

 

LINE型

×

 

LSEG型

△

 

MACADDR型

△

 

NUMERIC[(p,s)]型

○

 

PATH型

△

 

POINT型

△

 

POLYGON型

△

 

REAL型

○

 

SMALLINT型

○

 

SERIAL型

×

 

TEXT型

△

 

TIME[(P)]型

×

 

TIME[(P)] WITH TIME ZONE型

×

 

TIMESTAMP[(P)]型

○

 

TIMESTAMP[(P)] WITH TIME ZONE型

○

 

ARRAY型

△

 

UUID型

×

 

ENUM型

×

 

XML型

×

 

JSON型

×

 

JSONB型

×

 

RANGE型

×

 

  • ○:サポートします。

  • △:サポートしますが、制限事項があります。

  • ×:サポートしません。

 

テーブル読み取り処理

仕様制限

  • CHARACTER VARYING型、CHARACTER型、TEXT型

    • 最大バイト長は「10,485,760」です。

  • BYTEA型

    • 半角バックスラッシュ(「\」)と半角アポストロフィ(「'」)はサポートしません。

  • テーブル名が引用符で囲われている場合、テーブル名の大文字小文字を区別します。

  • フェッチサイズのデフォルト値は「500」です。

 

検索系SQL実行処理

仕様制限

  • CHARACTER VARYING型、CHARACTER型、TEXT型

    • 最大バイト長は「10,485,760」です。

  • BYTEA型

    • 半角バックスラッシュ(「\」)と半角アポストロフィ(「'」)はサポートしません。

  • フェッチサイズのデフォルト値は「500」です。

 

テーブル書き込み処理

仕様制限

  • 以下の型はサポートしません。

    • CIDR型

    • CIRCLE型

    • INTERVAL型

    • LSEG型

    • PATH型

    • POINT型

    • POLYGON型

    • BIT VARYING型

    • BIT VARYING(N)型

    • ARRAY型

    • INET型

    • MACADDR型

  • CHARACTER VARYING型、CHARACTER型、TEXT型

    • 最大バイト長は「10,485,760」です。

  • BYTEA型

    • 半角バックスラッシュ(「\」)と半角アポストロフィ(「'」)はサポートしません。

  • テーブル名が引用符で囲われている場合、テーブル名の大文字小文字を区別します。

  • アップデートモードのインサート・アップデートは使用できません。

 

更新系SQL実行処理

仕様制限

  • 以下の型はサポートしません。

    • CIDR型

    • CIRCLE型

    • INTERVAL型

    • LSEG型

    • PATH型

    • POINT型

    • POLYGON型

    • BIT VARYING型

    • BIT VARYING(N)型

    • ARRAY型

    • INET型

    • MACADDR型

  • CHARACTER VARYING型、CHARACTER型、TEXT型

    • 最大バイト長は「10,485,760」です。

  • BYTEA型

    • 半角バックスラッシュ(「\」)と半角アポストロフィ(「'」)はサポートしません。