システム動作環境設定(HULFT-HUB Server)

HULFT-HUB Serverで、ファイル転送の中継や同報配信をするための情報を登録します。

管理画面から、参照・更新ができます。

サーバのシステム動作環境設定画面で設定できる項目のうち、経路設定については経路情報、隣接サーバについては隣接サーバ情報、接続許可情報については接続許可情報を参照してください。

項目一覧

1. 環境設定

<表>システム動作環境設定(環境設定)

No. 項目名 初期値 設定値 指定 備考
A1 ホスト名

OSの設定値

(OS未設定時は"unknown")

英数字と
一部の記号 *4
*1  
A2 サービス名   英数字 *1  
A3 表示名 ホスト名の設定値 文字 任意 256バイト以内
A4 ポートNo. 40000 1~65535 *1  
A5 ユーザの通知 しない *3 任意  
A6 漢字コード種 SHIFT-JIS *3 必須  
A7 JIS年度 83JIS *3 必須  
A8 システム状況格納ディレクトリ *2 英数字 必須 128バイト以内
A9 管理情報格納ディレクトリ *2 英数字 必須 128バイト以内
A10 蓄積データ格納ディレクトリ *2 英数字 *1 128バイト以内
A11 蓄積データ抽出ワークディレクトリ *2 英数字 *1 128バイト以内
A12 転送履歴CSVファイル格納ディレクトリ *2 英数字 *1 128バイト以内
A13 管理情報バックアップ格納ディレクトリ *2 英数字 *1 128バイト以内
A14 DataMagicインストールディレクトリ   英数字 任意 128バイト以内
A15 DataMagic環境設定ディレクトリ   英数字 任意 128バイト以内
A16 HUB動作言語 *5 *3 必須  
*1: 参照のみ
*2: インストール時に設定されたディレクトリ。詳細は、「HULFT-HUB Server マニュアル」を参照してください。
*3: 設定値は画面上の選択肢から選択
*4: 「-(ハイフン)」「.(ピリオド)」のみ指定可能
*5: インストール時に指定した言語

2. 動作設定

<表>システム動作環境設定(動作設定)

No. 項目名 初期値 設定値 指定 備考
B1 転送処理の多重度 999 1~99999 必須  
B2 要求受付処理の多重度 999 1~99999 必須  
B3 ジョブフローの全体多重度 99 1~99 必須  
B4 Manager同時接続数 10 0~9999 *1  
B5 同報配信異常時の扱い 続行 *2 必須  
B6 同報配信異常扱いの条件 同報先どれか1つでエラー時 *2 必須  
B7 転送履歴しきい値 100000 0~999999 必須 単位: 件
B8 転送履歴保有件数 *3 *4 必須 単位: 件
B9 ジョブフロー履歴しきい値 100000 0~999999 必須 単位: 件
B10 ジョブフロー履歴保有件数 50000 *5 必須 単位: 件
B11 転送履歴CSVファイル保存月数 0 0~99 必須 単位: 月
B12 直接転送履歴バッチ処理間隔 0 0,5~1440 必須 単位: 分
B13 管理情報バックアップ間隔 0 0~99 必須 単位: 日
B14 管理情報バックアップ起動時刻 0300 0000~2359 必須  
B15 管理情報バックアップ対象 0 *2 必須  
B16 管理情報バックアップ保有世代数 0 0~99 必須  
B17 転送エラー解消確認区分 転送異常有無 *2 必須  
B18 HUB経由転送における通知ホスト名 ポート番号付きの形式 ― *1  
B19 蓄積関連ファイルの削除モード 通常モード *2 必須  
B20 圧縮方式の選択 共通圧縮方式 *2 必須  
*1: 参照のみ
*2: 設定値は画面上の選択肢から選択
*3: 「転送履歴しきい値」が“300”以下の場合: 0
  それ以外: 転送履歴しきい値-300件
*4: 「転送履歴しきい値」未満
*5: 「ジョブフロー結果しきい値」未満

3. 通信設定

<表>システム動作環境設定(通信設定)

No. 項目名 初期値 設定値 指定 備考
C1 クライアント稼動監視間隔 180 0、10~86400 必須 単位: 秒
C2 HUB Manager通信暗号化区分 HULFT暗号使用 *1 必須  
C3 HUB Server間暗号化区分 暗号化しない *1 必須  
C4 ソケット通信応答待ち時間 3600 0、10~259200 必須 単位: 秒
C5 ソケット接続リトライ回数 5 0~9999 必須  
C6 ソケット接続リトライ待ち時間 20 0~9999 必須 単位: 秒
C7 隣接HUBサーバ稼動監視間隔 3600 0、180~86400 必須 単位: 秒
*1: 設定値は画面上の選択肢から選択

4. 動作状況出力

<表>システム動作環境設定(動作状況出力)

No. 項目名 初期値 設定値 指定 備考
D1 トレースファイル名 $HULHUBETC/trace.log *1   必須 255バイト以内
D2 トレースファイル最大サイズ 10 0~1024 必須 単位: MB
D3 操作ログ出力モード ログ出力なし *2 必須  
D4 操作ログ自動切り換えサイズ 0 0~9999 必須  
D5 操作ログ世代管理数 9999 2~9999 必須  
D6 トレース取得モード 確認レベル以上を取得 *2 必須  
*1: 「HULHUBETC」はインストール時の設定によって異なります。「HULHUBETC」の詳細は、「HULFT-HUB Serverマニュアル」を参照してください。
*2: 設定値は画面上の選択肢から選択
【凡例】  
初期値 サーバ導入時の初期値
指定 画面上で管理情報を更新する際の指定の要否

各項目の説明

1. 環境設定

環境設定の各項目について説明します。

(A1)ホスト名

HULFT-HUB Serverのホスト名

【備考】 HULFT-HUB Managerからは変更できません。詳細は、「HULFT-HUB Server マニュアル」を参照してください。

(A2)サービス名

HULFT-HUB Serverのサービス名

【備考】 HULFT-HUB Managerからは変更できません。詳細は、「HULFT-HUB Server マニュアル」を参照してください。

(A3)表示名

HULFT-HUB Managerの画面上に表示されるHULFT-HUB Serverに対する表示名

(A4)ポートNo.

HULFT-HUB Serverが他のシステムと通信を行うためのポート番号

初期値として[サーバ登録]ダイアログにて登録されたHULFT-HUB Serverのポート番号が表示されます。

このポート番号は、オペレーティングシステムが予約しているポート番号、他のアプリケーションが使用するポート番号と重複しないように注意してください。

【備考】 HULFT-HUB Managerからは変更できません。詳細は、「HULFT-HUB Server マニュアル」を参照してください。

(A5)ユーザの通知

“する”を選ぶと、HULFT-HUB Managerのアカウント情報をHULFT-HUB Serverに通知することができます。

HULFT-HUB Serverの操作ログにおいて、「ユーザID(管理画面)」にはHULFT-HUB Serverへのログインアカウント、「ユーザID(OS)」にはHULFT-HUB ManagerのOSのユーザIDがそれぞれ保存されます。

初期値として“しない”が設定されています。

(A6)漢字コード種

使用しているシステムの漢字コード種

<表>「漢字コード種」の設定値

画面上の
選択肢
説明
SHIFT-JIS SHIFT-JIS
EUC EUC
UTF-8 UTF-8

(A7)JIS年度

使用しているシステムの漢字コードのJIS年度

<表>「JIS年度」の設定値

画面上の
選択肢
説明
78JIS 78年度 JIS
83JIS 83年度 JIS

(A8)システム状況格納ディレクトリ

転送状況やHULFT-HUB Serverの動作状況等の一時的な記憶ファイルを格納するディレクトリ

(A9)管理情報格納ディレクトリ

HULFT-HUB Serverが要求を処理するために使用するメモリ情報を格納するディレクトリ

(A10)蓄積データ格納ディレクトリ

蓄積データを格納するルートディレクトリ

HULFT-HUB Server が転送データを蓄積する場合の格納ルートディレクトリを絶対パスで指定します。指定ディレクトリが存在しない場合、HULFT-HUB Server は起動しません。

HULFT-HUB Server-ENT の場合にのみ有効です。

【備考】 HULFT-HUB Managerからは変更できません。

(A11)蓄積データ抽出ワークディレクトリ

ジョブフロー機能で蓄積データの抽出用に使用するディレクトリを絶対パスで指定します。指定ディレクトリが存在しない場合、HULFT-HUB Server は起動しません。

HULFT-HUB Server-ENT の場合にのみ有効です。

【備考】 HULFT-HUB Managerからは変更できません。

(A12)転送履歴CSVファイル保存ディレクトリ

CSV 形式の転送履歴を保存するディレクトリを絶対パスで指定します。指定ディレクトリが存在しない場合、HULFT-HUB Server は起動しません。

【備考】 HULFT-HUB Managerからは変更できません。

(A13)管理情報バックアップ格納ディレクトリ

管理情報バックアップ格納ディレクトリを絶対パスで指定します。指定ディレクトリが存在しない場合、HULFT-HUB Server は起動しません。

【備考】 HULFT-HUB Managerからは変更できません。

(A14)DataMagicインストールディレクトリ

ジョブフロー機能でHULFT-DataMagic 起動用に使用するディレクトリを絶対パスで指定します。ジョブフローでHULFT-DataMagic を呼び出す場合に指定してください。

HULFT-HUB Server-ENT の場合にのみ有効です。

(A15)DataMagic環境設定ディレクトリ

ジョブフロー機能でHULFT-DataMagic 起動用に使用するディレクトリを絶対パスで指定します。ジョブフローでHULFT-DataMagic を呼び出す場合に指定してください。

HULFT-HUB Server-ENT の場合にのみ有効です。

(A16)HUB動作言語

HULFT-HUB Serverがメッセージを出力する際の言語

<表>「HUB動作言語」の設定値

画面上の
選択肢
説明
日本語 日本語で出力
英語 英語で出力

本項目の影響を受けるのは、以下の内容です。

  • トレースログ
  • ユーティリティの出力

 

2. 動作設定

動作設定の各項目について説明します。

(B1)転送処理の多重度

HULFT-HUB Serverで同時に実行可能な「転送処理(ファイル転送の中継処理と同報配信の合計)」の最大数

(B2)要求受付処理の多重度

HULFT-HUB Serverで同時に実行可能な「要求受付系サービスの中継」の最大数

(B3)ジョブフローの全体多重度

同時実行可能な「ジョブフロー処理」の最大数を指定します。

HULFT-HUB Server-ENT の場合にのみ有効です。

(B4)Manager同時接続数

HULFT-HUB Serverに同時に接続できるHULFT-HUB Managerのユーザ数

【備考】 HULFT-HUB Managerからは変更できません。詳細は、「HULFT-HUB Server マニュアル」を参照してください。

(B5)同報配信異常時の扱い

同報配信中に、いくつかの転送先ホストへの転送で何らかのエラーが発生した場合、その他の転送先ホストに対する配信処理の扱い

<表>「同報配信異常時の扱い」の設定値

画面上の
選択肢
説明
中断 即時に同報配信を中断します。
続行 転送異常を検知したホストとの転送のみを中断し、それ以外のホストへは処理を続行します。

(B6)同報配信異常扱いの条件

同報配信中に、いくつかのホストへの転送でエラーが発生した場合、配信側ホストへ転送異常を通知する条件

<表>「同報配信異常扱いの条件」の設定値

画面上の
選択肢
説明
同報先どれか1つでエラー時 一部の転送先ホストとのファイル転送に失敗した場合でも転送異常を通知します。
全転送でエラー時 すべての転送先ホストとのファイル転送に失敗した場合に転送異常を通知します。

初期値として“同報先どれか1つでエラー時”が選択されています。

本項目の指定は、「同報配信異常時の扱い」に“続行”を選択した場合に、有効になります。

(B7)転送履歴しきい値

転送履歴の件数が当該指定値を超えた場合、「転送履歴保有件数」を残して自動削除されます。

“0”を指定した場合、自動削除されません(無制限に蓄積されます)。

(B8)転送履歴保有件数

転送履歴の件数が「転送履歴しきい値」を超えた場合、当該指定値を残して自動削除されます。「転送履歴のしきい値」に“0”が設定されている場合、本項目を指定しても有効になりません。

初期値として、「転送履歴しきい値-300(件)」が設定されています。「転送履歴しきい値」が300以下の場合、“0”が設定されています。

(B9)ジョブフロー履歴しきい値

ジョブフロー結果の件数が指定値を超えた場合、「ジョブフロー履歴保有件数」の指定値分だけ残して自動削除します。

HULFT-HUB Server-ENT の場合にのみ有効です。

• 0 : 自動削除しません(無制限に蓄積されます)。
• 1~999999 : 指定値に従い、自動削除します。

(B10)ジョブフロー履歴保有件数

ジョブフロー結果の件数が「ジョブフロー履歴しきい値」の指定値を超えた場合、本指定値分のジョブフロー履歴を残して古い履歴から自動削除します。「ジョブフロー履歴しきい値」が“0”の場合、本項目の指定値は意味を持ちません。

HULFT-HUB Server-ENT の場合にのみ有効です。

【注意】 ジョブフロー履歴の件数が「ジョブフロー履歴しきい値」の指定値を超えたことが検知された場合、「ジョブフロー履歴保有件数」で設定された件数まで履歴を削除した後に、新たな履歴が追加されます。

(B11)転送履歴CSVファイル保存月数

転送履歴をCSV 形式で保存する場合の保存月数を指定します。

• 0 : 保存しません。
• 1~99 : 指定値に従い、保存します。

(B12)直接転送履歴バッチ処理間隔

直接転送履歴集約のバッチ処理起動を行う間隔を指定します。

• 0 : 定期的なバッチ処理起動は行いません。
• 5~1440 : 指定された間隔で直接転送履歴集約のバッチ処理起動を行います。

サーバのシステム動作環境設定画面では「バッチ処理間隔」と表示されます。

(B13)管理情報バックアップ間隔

管理情報を定期的にバックアップする間隔を指定します。

• 0 : 定期的なバックアップは行いません。
• 1~99 : 指定された間隔でバックアップを行います。

サーバのシステム動作環境設定画面では「バックアップ間隔」と表示されます。

(B14)管理情報バックアップ起動時刻

管理情報を定期的にバックアップする時刻を指定します。

サーバのシステム動作環境設定画面では「バックアップ実行時刻」と表示されます。

(B15)管理情報バックアップ対象

バックアップ対象の管理情報とバックアップの条件を指定します。

<表>「管理情報バックアップ対象」の設定値

画面上の
選択肢
説明
すべてを更新があった場合のみ取得 すべてのシステム管理情報(*)の中で、更新があったものをバックアップします。
すべてを常に取得 すべてのシステム管理情報(*)を、更新の有無にかかわらずバックアップします。
一部を更新があった場合のみ取得 一部のシステム管理情報(*)の中で、更新があったものをバックアップします。
一部を常に取得 一部のシステム管理情報(*)を、更新の有無にかかわらずバックアップします。

「すべてのシステム管理情報」と「一部のシステム管理情報」が表す範囲は以下のようになります。

<表>「すべての管理情報」と「一部の管理情報」

システム管理情報の種別 すべての
システム管理情報
一部の
システム管理情報
SVR
(*1)
MGR
(*2)
サーバの
システム管理情報
代替管理情報 ○      
ユーザ情報 ○   ○  
業務権限情報 ○   ○  
業務グループ情報 ○   ○  
クライアント業務グループ情報 ○      
収容クライアント情報 ○      
転送情報 ○ ○ ○ ○
転送詳細条件 ○ ○ ○ ○
転送先ホスト情報 ○ ○ ○ ○
ホストグループ情報 ○      
隣接サーバ情報 ○      
経路情報 ○      
クライアント状態管理 ○      
蓄積環境設定 ○   ○  
ジョブフロー管理情報 ○      
クライアントの
システム管理情報
クライアントシステム動作環境設定 ○      
クライアントインストール情報 ○      
配信管理情報 ○ ○ ○ ○
集信管理情報 ○ ○ ○ ○
転送グループ情報 ○ ○ ○ ○
詳細ホスト情報 ○ ○ ○ ○
ジョブ管理情報 ○ ○ ○ ○
フォーマット情報 ○ ○ ○ ○
マルチフォーマット情報 ○ ○ ○ ○
スケジュール情報 ○ ○ ○ ○
メール連携情報 ○ ○ ○ ○
XML変換情報 ○ ○    
ファイルトリガ情報 ○ ○ ○ ○
*1: HULFT-HUB Serverの管理情報パラメータ生成ユーティリティ(utlhubigen)でバックアップファイルからパラメータファイルを作成可能かどうかを表します。
*2: 管理情報収集配布画面でバックアップファイルから管理情報を取得可能かどうかを表します。

(B16)管理情報バックアップ保有世代数

バックアップされた管理情報を保持する世代数です。バックアップされた管理情報の数が指定した値を超える場合、保持している最古のバックアップを削除します。

• 0 : 自動削除しません(無制限に蓄積されます)。
• 1~99 : 指定された世代数のバックアップを保持します。

サーバのシステム動作環境設定画面では「バックアップ保有世代数」と表示されます。

(B17)転送エラー解消確認区分

転送エラー解消(構成図でサーバを正常表示へ自動遷移)のモードを選択します。

<表>「転送エラー解消確認区分」の設定値

画面上の
選択肢
説明
転送異常有無 一度エラーになった転送履歴に対して転送が正常に行われた場合に、転送エラーを解消します。
送出異常有無 蓄積一覧に送出異常の履歴がなくなった場合に、転送エラーを解消します。

転送エラーが解消された後で構成図が(自動または手動で)最新の状態に更新されると、サーバのアイコンが正常表示に戻ります。

(B18)HUB経由転送における通知ホスト名

HUBを経由した転送で、転送情報を作成した際にクライアントに登録される相手ホストのホスト名、および転送を実行した際に通知される相手ホストのホスト名の形式

【備考】 HULFT-HUB Managerからは変更できません。詳細は、「HULFT-HUB Server マニュアル」を参照してください。

<表>「HUB経由転送における通知ホスト名」の設定値

画面上の
選択肢
説明
ポート番号付きの形式 すべてのクライアントで「ホスト名_集信ポートNo.」の形式
管理対象のみポート番号付きの形式 管理対象クライアントでは「ホスト名_ポートNo.」の形式
管理対象外クライアントでは「ホスト名」の形式
ポート番号無しの形式 すべてのクライアントで「ホスト名」の形式

(B19)蓄積関連ファイルの削除モード

蓄積ファイルを削除するとき、後で復元できないような処理を行うかどうかを選択します。

<表>「蓄積関連ファイルの削除モード」の設定値

画面上の
選択肢
説明
通常モード 従来と同じ方法で削除します。
復元不可能モード 復元不可能にする処理を行ったうえで削除します。

代替機能を使用している場合、代替機側でも本項目を設定してください。

(B20)圧縮方式の選択

集信側が配信側で指定した圧縮方式に対応していない場合に、どの圧縮方式を使用するかを選択します。

HULFT-HUBの「圧縮方式の選択」は、HULFT側の「圧縮方式の選択」が“共通圧縮方式”の場合のみ有効となります。

<表>「圧縮方式の選択」の設定値

画面上の
選択肢
説明
共通圧縮方式

配信側と集信側で共通して使用できる圧縮方式のうち、最も圧縮効率が高い圧縮方式を使用します。

圧縮効率の順位は以下のとおりです。

「Zstandard圧縮」>「DEFLATE圧縮」>「圧縮なし」

圧縮なし 集信側の圧縮方式が配信側で指定した圧縮方式に対応していない場合は「圧縮なし」

 

3. 通信設定

通信設定の各項目について説明します。

(C1)クライアント稼動監視間隔

HULFT-HUB Serverから収容クライアントに対して、定期的なポーリングにより稼動状況を監視するための間隔

“0”を指定した場合、定期的なポーリングによる稼動状況の監視を行いません。

【備考】  
• Ver.6以降のクライアントが対象です。
• 稼動状況により、構成図上のクライアントアイコンの色が以下のように表示されます。
  カラー表示: クライアントが稼動状態
  黒色: クライアントが停止状態

(C2)HUB Manager通信暗号化区分

HULFT-HUB Serverから送信される制御情報を暗号化するかどうかを選択します。

サーバがHULFT-HUB Server Ver.3.9.0未満の場合のみ指定可能です。

サーバがHULFT-HUB Server Ver.3.9.0以降の場合、制御情報は常に暗号化されます。

<表>「HUB Manager通信暗号化区分」の設定値

画面上の
選択肢
説明
暗号化しない 暗号化しません。
HULFT暗号使用 HULFT 暗号方式で暗号化します。

(C3)HUB Server間暗号化区分

隣接サーバへ送信する電文を暗号化するかしないかを指定します。

HULFT-HUB Server-ENT の場合にのみ有効です。

<表>「HUB Server間暗号化区分」の設定値

画面上の
選択肢
説明
暗号化しない 暗号化しません。
HULFT暗号 HULFT 暗号方式で暗号化します。
C4S暗号優先 C4S方式で暗号化します。
AES暗号優先 AES方式で暗号化します。

(C4)ソケット通信応答待ち時間

コネクション接続後の無通信監視で使用するタイムアウト値

“0”を指定した場合、応答が返されるまで無制限に待ちます。

(C5)ソケット接続リトライ回数

ソケット接続に失敗した時、再接続を試みる回数

“0”を指定した場合、再接続を試みません。

(C6)ソケット接続リトライ待ち時間

ソケット接続に失敗した時、再接続を試みるまでの待ち時間

“0”を指定した場合、応答が返されるまで無制限に待ちます。

(C7)隣接HUBサーバ稼動監視間隔

隣接サーバの稼動監視を行う間隔

“0”を指定した場合、稼動監視を行いません。

HULFT-HUB Server Ver.3.9.0以降で指定可能です。

 

4. 動作状況出力

動作状況出力の各項目について説明します。

(D1)トレースファイル名

トレース情報を取得する際の格納先ファイル名

フルパスで指定します。

「トレース取得モード」で、いずれかのデーモン、プログラムに“取得しない”以外を指定した場合に有効になります。

(D2)トレースファイル最大サイズ

トレースファイルの最大サイズ

トレースの蓄積量が本設定値を超えた場合、バックアップを取得して、新たなトレースファイルを作成します。

バックアップファイルは「トレースファイル名」に“.bk”を付加した名前で、同一ディレクトリに作成され、一世代だけ保存されます。

“0”を指定した場合、無制限に蓄積されます。

(D3)操作ログ出力モード

操作ログの出力モードを指定します。

【備考】 操作ログはVer.2.2.0以降のサーバで設定可能です。

(D4)操作ログ自動切り換えサイズ

操作ログ自動切り換えサイズを指定します。

【備考】 操作ログはVer.2.2.0以降のサーバで設定可能です。

(D5)操作ログ世代管理数

操作ログ世代管理数を指定します。

【備考】 操作ログはVer.2.2.0以降のサーバで設定可能です。

(D6)トレース取得モード

トレースファイルに出力するメッセージのレベルを、デーモンおよびプログラムごとに選択します。

<表>「トレース取得モード」の設定値

画面上の
選択肢
説明
取得しない トレース情報は記録されません
致命的なエラーのみ取得 致命的なエラーが発生した場合、トレース情報を記録します。
エラーレベル以上を取得 致命的なエラー、軽度のエラーが発生した場合、トレース情報を記録します。
警告レベル以上を取得 致命的なエラー、軽度のエラー、警告レベルの事象が発生した場合、トレース情報を記録します。
確認レベル以上を取得 致命的なエラー、軽度のエラー、警告レベルの事象、確認レベルの事象が発生した場合、トレース情報を記録します。

指定できるデーモン、プログラムは下記のとおりです。

  •HUBデーモン
  •PROXYデーモン
  •中継デーモン
  •同報デーモン
  •送出デーモン
  •Managerデーモン
  •稼動監視プログラム
  •ユーティリティプログラム
  •ジョブフローデーモン
  •ジョブフロー実行プログラム
  •ジョブフローユーティリティ

各デーモン、プログラムの詳細は、「HULFT-HUB Server マニュアル」を参照してください。